KB 0011
I can connect to your OPC Server from an OPC Client on the local PC, but cannot connect to the OPC Server from a remote PC.


CATEGORY

OPC DA Server

 

SYMPTOMS

I can connect to your OPC Server from an OPC Client on the local PC, but cannot connect to the OPC Server from a remote PC. Error indication is 'Access is Denied.'

 

CAUSE

Default DCOM settings vary from system to system. Generally, default DCOM settings on the server machine restrict OPC Client applications from accessing a remote OPC Server.

Windows Firewall can also present problems on Windows XP higher systems.

 

RESOLUTION

Refer to this technical note for Automated Solutions' recommended settings: (Requires PDF Reader)

DCOM and Windows Firewall Configuration for Automated Solutions OPC Servers