KB 0025
HTML Help system used in Automated Solutions products shows tree structure on the left, but content pages do not show.


CATEGORY

ASComm.NET

 

SYMPTOMS

When I open Help, the left pane shows the Contents, Index, Search, and Favorites tabs, but the right pane does not show content pages.

 

CAUSE

HTML Help files (CHM) consist of compiled HTML files, which can contain harmful scripts. That is why Windows security updates may block its content.

 

SOLUTION

To unblock a trusted CHM file:

  1. Using Windows Explorer, navigate to the HTML Help file (*.chm) located in the installation directory (see table below).
  2. Right click the CHM file and select "Properties" on the popup menu.
  3. On the "General" tab, click the "Unblock" button.
  4. Then click "OK".

After the Help files have been unblocked, the files will remain unblocked and the Unblock button will disappear

 

Help File Locations

Product Line Help File Path For x86 Systems Help File Path For x64 Systems
ASComm.NET
Version 3.6*
C:\Program Files\Automated Solutions\ASComm.NET 3.6\AutomatedSolutions.ASComm.chm

C:\Program Files\Automated Solutions\ASComm.NET 3.6\AutomatedSolutions.ASComm.Namespaces.chm
C:\Program Files\Automated Solutions\ASComm.NET 3.6\AutomatedSolutions.ASComm.chm

C:\Program Files\Automated Solutions\ASComm.NET 3.6\AutomatedSolutions.ASComm.Namespaces.chm
ActiveX Controls
Version 2.0*
C:\Program Files\Automated Solutions\ActiveX\<Product Name> 2.0\<Product Name>.chm C:\Program Files (x86)\Automated Solutions\ActiveX\<Product Name> 2.0\<Product Name>.chm
OPC Servers
All versions
C:\Program Files\Automated Solutions\OPC\<Product Name>\<Product Name>.chm C:\Program Files (x86)\Automated Solutions\OPC\<Product Name>\<Product Name>.chm

* Your version number may be different. Since the version number is included the path, substitute your version number for the version number shown in the Help File Path..